Blog sobre seguridad informática, privacidad, anonimato, hacking ético, programación y sistemas operativos en general.

Visitas al blog!

Ayúdanos a seguir.

Páginas Amigas

viernes, 29 de septiembre de 2017

WebHackSHL 2.0 con soporte para Server Side Template Injection.


WebHackSHL, nuestra herramienta de hacking web, la cual está diseñada para ser rápida, eficiente, de fácil uso y estar actualizada, ahora tiene soporte para realizar auditorías de seguridad, búsqueda de fallos y explotación de la vulnerabilidad Server Side Template Injection, la cual explicamos en un post anterior; además de eso también fueron modificadas y optimizadas varias líneas de código, corregidos varios fallos y actualizada a su versión 2.0-Estable. Si deseas conocer más acerca de esta herramienta desarrollada por Security Hack Labs puedes leer aquí. La herramienta es de código abierto y pueden descargarla desde https://github.com/sechacklabs/webhackshl, esta herramienta trabaja en sistemas basados en Debian cómo Kali Linux y tambien basados en ArchLinux cómo BlackArch.

Imágenes de la herramienta.




Si tienen peticiones y sugerencias para añadir nuevas funciones a la herramienta, pueden hacernosla saber mediante Github o bien en nuestra sala de Riot https://riot.im/app/#/room/#sechacklabs:matrix.org.

Síguenos en Facebook, Twitter y unete a nuestra charla en Riot (Para charlar con nosotros online).


6 comentarios:

  1. Excelente herramienta, simplifica muchas ejecuciones y los reportes totalmente claros.

    ResponderEliminar
  2. Al ejecutarlo marca esto:
    Reading state information... Done
    E: Unable to locate package python2
    E: Unable to locate package python2-requests
    E: Unable to locate package python2-yaml
    E: Unable to locate package python2-flask
    Ha ocurrido un error, intentando nuevamente.

    ResponderEliminar
    Respuestas
    1. Hola ¿Podrías especificarnos que sistema operativo estás usando y cual es su versión?

      Eliminar
    2. Claro, Kali Linux 2017.1

      Cuando doy la opcion -ut, marca:
      actualizando Herramientas del sistema...
      Traceback (most recent call last):
      File "webhackshl.py", line 45, in
      checker.utools()
      File "/root/Documents/WebHackSHL-master/modules/checker.py", line 269, in utools
      updatetools(DISTRO)
      File "/root/Documents/WebHackSHL-master/modules/checker.py", line 87, in updatetools
      correctinstall==os.system("sudo apt install --only-upgrade nmap fierce sqlmap dnsenum nikto whatweb wpscan ruby git curl tor gzip john python2 python2-requests python2-yaml python2-flask && cd modules/tplmap/ && git pull")
      UnboundLocalError: local variable 'correctinstall' referenced before assignment

      Saludos

      Eliminar
    3. Ya he modificado el código, intenta lo siguiente: python2 webhackshl.py -u && python2 webhackshl.py -ut. Con eso debe solucionarse, si el error persiste ingresa a https://riot.im/app/#/room/#securityhacklabs:matrix.org

      Eliminar
    4. Ok con GIT quedó, merci beacoup!

      Eliminar